$ in identifiers -- poll

Jack Jansen jack at vu44.UUCP
Fri Jan 4 05:31:12 AEST 1985


> How about this construct:
> 
> 	extern sys_read() : "SYS$READ";
> 
I think that it should be closer to the identifier. It is the
identifier that is modified, after all.
If you don't want to use 'entry', the use ':', but keep it next to
the identifier, something like
	extern sys_read:"SYS$READ"();

This is also much more readable in the case of *defining*
funny names, which hasn't been discussed yet, but which can
be just as useful, for instance when you're writing a
library and you want to hide your internal routines.

By the way, I'm still in favor of using 'entry' in stead of
Yet Another Funny Char. This usage won't even make the entry
symbol unusable, since the use of entry for defining entrypoints
is presumably somewhere inside the *code*, not the declarations.
-- 
	Jack Jansen, {seismo|philabs|decvax}!mcvax!vu44!jack
	or				       ...!vu44!htsa!jack
If *this* is my opinion, I wasn't sober at the time.



More information about the Comp.lang.c mailing list